gradle 3.x runs without setting _JAVA_OPTIONS on jdk-9+175 (and later)

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

gradle 3.x runs without setting _JAVA_OPTIONS on jdk-9+175 (and later)

Kevin Rushforth
Now that '--illegal-access=permit' is the default for JDK 9 (as of build
175) I can confirm that gradle 3.x works without needing to specify a
bunch of '--add-opens' options. I was able to do an entire build / test
of JavaFX without setting _JAVA_OPTIONS at all. I hope this will give
the groovy and gradle teams the time they need to fix all remaining issues.

-- Kevin

Loading...