"The State of the Module System" should be marked as outdated

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

"The State of the Module System" should be marked as outdated

Volker Simonis
Hi,

I think this has been mentioned before, but "The State of the Module
System" under http://openjdk.java.net/projects/jigsaw/spec/sotms/ is
outdated and constantly keeps confusing people. E.g. it still uses
"requires public" instead of "requires transitive"

Can you please either update the document or put a banner on top of
that page which mentions that it is at least partially outdated (maybe
with a link to the latest version of the specification).

Thank you and best regards,
Volker
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: "The State of the Module System" should be marked as outdated

mark.reinhold
2017/7/27 6:31:19 -0700, [hidden email]:
> I think this has been mentioned before, but "The State of the Module
> System" under http://openjdk.java.net/projects/jigsaw/spec/sotms/ is
> outdated and constantly keeps confusing people. E.g. it still uses
> "requires public" instead of "requires transitive"

A major update of this document is in preparation.  In the meantime I've
added an explanatory note to the top of the current version.

- Mark
Loading...